MakerLab创客实验室 — Let's Make something.
现在注册
已注册用户请 登入
jackylin large avatar
MakerLab创客实验室  ›  新手入门

新手提问kossel delta使用mega2560+ramps1.4接好电机,怎一启动回归原点轴向是先向下运行,电机线也反装同样情况,

By jackylin at 2 年前 , 3753 次浏览

新手2个提问kossel delta使用mega2560+ramps1.4接好电机,
1.怎一启动回归原点轴向是先向下运行,电机线也反装同样情况,是否有参数未修改
2.接了显示屏为12864,接上电源器显示屏不显示,需接上USB至电脑才能显示,要如何脱机显示

4 回复
Andy medium avatar
#1 - 2 年前
Andy

1、首先确定你使用的delta固件,另外电机线反接后应该会反向,比如原来A-A+B+B-改为B-B+A+A-试试;
2、那是因为ramps上有一个二极管没有焊接,你可以自己焊上D1(在xy轴4988底下),但是如果焊接,电源电压最好是12V,太高电压容易烧板子。

你试试看

jackylin medium avatar
#2 - 2 年前
jackylin

Connecting...
start
Printer is now online.
echo: External Reset
Marlin 1.0.0
echo: Last Updated: Aug 4 2014 19:24:31 | Author: (MakerLab, Delta)
Compiled: Aug 4 2014
echo: Free Memory: 2998 PlannerBufferBytes: 1232
echo:Hardcoded Default Settings Loaded
echo:Steps per unit:
echo: M92 X80.00 Y80.00 Z80.00 E100.00
echo:Maximum feedrates (mm/s):
echo: M203 X200.00 Y200.00 Z200.00 E200.00
echo:Maximum Acceleration (mm/s2):
echo: M201 X9000 Y9000 Z9000 E9000
echo:Acceleration: S=acceleration, T=retract acceleration
echo: M204 S3000.00 T3000.00
echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
echo: M205 S0.00 T0.00 B20000 X20.00 Z20.00 E20.00
echo:Home offset (mm):
echo: M206 X0.00 Y0.00 Z0.00
echo:Endstop adjustement (mm):
echo: M666 X0.00 Y0.00 Z0.00
echo:PID settings:
echo: M301 P22.20 I1.08 D114.00
Error:0
[ERROR] Error:0

: Extruder switched off. MINTEMP triggered !
Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)
[ERROR] Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)

echo:SD init fail
这是在上位机连线给出的讯号,先前在限位开关接线是接错,应该有导致板短路冒烟赶紧关电源,不知是否真是板烧坏所以电机轴向失调

jackylin medium avatar
#3 - 2 年前
jackylin

是上传楼主的中文delta固件,把电机线反了装也是一样的情况,是否真是MEGA2560板短路烧坏(冒烟是这板上电源接头旁那个长方体元件),另ramps上D1那二极管是有焊上的,但接了电源器200-240V/29A-12V仍须要插上USB线显示屏才能显示,是否有参数未设定,求教感谢

Andy medium avatar
#4 - 2 年前
Andy

@jackylin 应该是mega2560板子上的电源芯片烧掉了,可以尝试更换一个试试